summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:54:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:22 +0200
commit940d00adda7cd28ab4600d6d5e29f1477ee91d18 (patch)
treeada9f7ad3530ce8aadcaaf834734c5a952661138 /gnu
parent9e6e3981785162810d9808b19df5c33905befae3 (diff)
gnu: Add texlive-luainputenc.
* gnu/packages/tex.scm (texlive-luainputenc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index efa5ee793c..19ece13c73 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16497,6 +16497,29 @@ graphics.")
"Luaindex provides (yet another) index processor, written in Lua.")
(license license:lppl1.3+)))
+(define-public texlive-luainputenc
+ (package
+ (name "texlive-luainputenc")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/luainputenc/"
+ "source/lualatex/luainputenc/"
+ "tex/lualatex/luainputenc/")
+ (base32
+ "17xglqil5mbv47kjzklp22vvsn29vajf6q0v45af4pd6yk9kcc6w")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/luainputenc")
+ (synopsis "Replacing @code{inputenc} for use in LuaTeX")
+ (description
+ "LuaTeX operates by default in UTF-8 input; thus LaTeX documents that
+need 8-bit character-sets need special treatment. The package, therefore,
+replaces the LaTeX standard @code{inputenc} for use under LuaTeX. With
+a current LuaTeX,the package has the same behaviour with LuaTeX as
+@code{inputenc} has under pdfTeX.")
+ (license license:public-domain)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")