summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:54:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:22 +0200
commit9e6e3981785162810d9808b19df5c33905befae3 (patch)
tree0355088f2ae402457a0d7ec5bae54a3f812d765c /gnu
parent7ab5567de0a960e32e50e3bae7fc05bc05c0b0a7 (diff)
gnu: Add texlive-luaindex.
* gnu/packages/tex.scm (texlive-luaindex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e4b2e38a9e..efa5ee793c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16470,6 +16470,33 @@ with images into a single TeX file, or with automatically generated
graphics.")
(license license:expat)))
+(define-public texlive-luaindex
+ (package
+ (name "texlive-luaindex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/luaindex/" "scripts/luaindex/"
+ "source/lualatex/luaindex/"
+ "tex/lualatex/luaindex/")
+ (base32
+ "0a2xfzrc663jmd2s5vi5p38pwd16mbm5602pxc3kszza8whqlfdn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list #:tex-format "lualatex"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; FIXME: Building documentation requires shell-escape to be
+ ;; allowed. I couldn't find a way to generate the package
+ ;; only.
+ (delete 'build))))
+ (home-page "https://ctan.org/pkg/luaindex")
+ (synopsis "Create index using LuaLaTeX")
+ (description
+ "Luaindex provides (yet another) index processor, written in Lua.")
+ (license license:lppl1.3+)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")