summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:40:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:49 +0200
commit97c4a0c26fcc79fb2703dd79b32ac1e08f1f0609 (patch)
tree661bf8aee287eb2515ba2634b2e54804f8451d9d /gnu
parent9e13ed5d5bb725b05888e1b01fa51d7d14fc048a (diff)
gnu: Add texlive-vocaltract.
* gnu/packages/tex.scm (texlive-vocaltract): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b5a59b81c0..3030f32295 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34541,6 +34541,30 @@ texts written using LaTeX. The package macros make use of commands of
PSTricks.")
(license license:lppl)))
+(define-public texlive-vocaltract
+ (package
+ (name "texlive-vocaltract")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/vocaltract/"
+ "tex/latex/vocaltract/")
+ (base32
+ "072b712bhfxq429jh4r9d786nwpdyl8rlbm6ds4nf9asxg2lg9wr")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/vocaltract")
+ (synopsis "Visualise the vocal tract using LaTeX and PSTricks")
+ (description
+ "The package enables the user to visualise the vocal tract. The vocal
+tract (in the package) is manipulated by a vector of articulation parameters
+according to the S. Maeda model. Animation may be achieved by providing
+a sequence of vectors over time (e.g., from Matlab). A sequence of vectors
+for certain German phonemes is embedded in the package, which allows for
+animation when no other vector is available. The package's graphics are
+produced using PSTricks.")
+ (license license:lppl)))
+
(define-public texlive-xkeyval
(package
(name "texlive-xkeyval")