summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 15:55:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:05 +0200
commit98cf64ec2f23ac8424ff23e492d239e486470c2c (patch)
treeec4e15686fd46527de9b22cede53579c3a78aac4 /gnu
parentf598b0fb97db4352692843096c2e39993199b23c (diff)
gnu: Add texlive-xesearch.
* gnu/packages/tex.scm (texlive-xesearch): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ef757ed369..26680d6f0d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7356,6 +7356,28 @@ occurrence then creates an index entry whose content can be fully specified
beforehand.")
(license license:lppl)))
+(define-public texlive-xesearch
+ (package
+ (name "texlive-xesearch")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/xetex/xesearch/" "tex/xetex/xesearch/")
+ (base32
+ "13fdllqswyyvvyjqn0a4ld18dixxnn7zlpagsdaq8cl1svpaxpk5")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xesearch")
+ (synopsis "String finder for XeTeX")
+ (description
+ "The package finds strings (e.g., parts of words or phrases) and
+manipulates them, thus turning each word or phrase into a possible command.
+It is written in plain XeTeX and should thus work with any format. The main
+application for the moment is XeIndex, an automatic index for XeLaTeX, but
+examples are given of simple use to check spelling, count words, and highlight
+syntax of programming languages.")
+ (license license:lppl)))
+
(define-public texlive-currfile
(package
(name "texlive-currfile")