summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 15:55:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:05 +0200
commitf598b0fb97db4352692843096c2e39993199b23c (patch)
tree5e6f8fefedbbc10fda71172057c64f1a3a826301 /gnu
parent4fb5d377ff61cf37742749d666410d7017cc63e7 (diff)
gnu: Add texlive-xeindex.
* gnu/packages/tex.scm (texlive-xeindex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 83c06a7d70..ef757ed369 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7335,6 +7335,27 @@ without any problem.")
XeLaTeX and @code{babel}.")
(license license:lppl1.3+)))
+(define-public texlive-xeindex
+ (package
+ (name "texlive-xeindex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/xelatex/xeindex/"
+ "tex/xelatex/xeindex/")
+ (base32
+ "1sps9lrzm9y2rrin5pkgzyk56c77xnydvp21ljmvsimqgafr5aqb")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xeindex")
+ (synopsis "Automatic index generation for XeLaTeX")
+ (description
+ "The package is based on XeSearch, and will automatically index words or
+phrases in an XeLaTeX document. Words are declared in a list, and every
+occurrence then creates an index entry whose content can be fully specified
+beforehand.")
+ (license license:lppl)))
+
(define-public texlive-currfile
(package
(name "texlive-currfile")