summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:22:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:49:28 +0200
commit9b542119c965f81f4355b2871a0c4770d9ce87b5 (patch)
treed0f7c39a8509f250cee2dad08c494f79fc023b92 /gnu
parent357612be210cc37846f5e3bae95bcac2ceee0b82 (diff)
gnu: Add texlive-rubik.
* gnu/packages/tex.scm (texlive-rubik): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 88140bd861..3f7fffbb17 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12688,6 +12688,46 @@ German lawyers. Now in the early beginning it only contains @code{rtklage},
a class to make lawsuits.")
(license license:lppl)))
+(define-public texlive-rubik
+ (package
+ (name "texlive-rubik")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/rubik/"
+ "doc/man/man1/rubikrotation.1"
+ "doc/man/man1/rubikrotation.man1.pdf"
+ "scripts/rubik/"
+ "source/latex/rubik/"
+ "tex/latex/rubik/")
+ (base32
+ "0v7j88d72acgrj24x8g859k7q6qd47pjy3wdqfvrqq3y39x48011")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "rubikrotation.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/rubik")
+ (synopsis "Document Rubik cube configurations and rotation sequences")
+ (description
+ "The bundle provides four packages:
+@itemize
+
+@item @code{rubikcube} provides commands for typesetting Rubik cubes
+and their transformations,
+
+@item @code{rubiktwocube} provides commands for typesetting Rubik
+twocubes and their transformations,
+
+@item @code{rubikrotation} can process a sequence of Rubik rotation
+moves, with the help of a Perl package executed via
+@code{\\write18} (shell escape) commands,
+
+@item @code{rubikpatterns} is a collection of well known patterns and
+their associated rotation sequences.
+
+@end itemize")
+ (license license:lppl1.3+)))
+
(define-public texlive-sankey
(package
(name "texlive-sankey")