summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:25:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:11 +0200
commita8308aa4187b03c4db05a8558b1840f6953b3f50 (patch)
tree2d883d51a7941145de8cc89ef8568f891be4bf12 /gnu
parentaa11f73eebc607938ab02e46564a3d3bc817ef87 (diff)
gnu: Add texlive-yax.
* gnu/packages/tex.scm (texlive-yax): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a633ddbc71..f597b36c9f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12996,6 +12996,29 @@ standards-compliant PDF documents with pdfTeX, LuaTeX and XeTeX.")
(define-deprecated-package texlive-latex-pdfx texlive-pdfx)
+(define-public texlive-yax
+ (package
+ (name "texlive-yax")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/yax/" "tex/generic/yax/")
+ (base32
+ "01hv550qkmxw63m41v4qykfiracvzvjwxk49y6fc6abg89hfvsj6")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/yax")
+ (synopsis "Yet Another Key System")
+ (description
+ "YaX is advertised as a key system, but it rather organizes attributes in
+parameters, which parameters can be executed, so that YaX is halfway between
+key management and macro definition (and actually hopes to provide a user's
+interface). Values assigned to attributes can be retrieved and tested in
+various ways, with full expandability ensured as much as possible. Finally,
+YaX's syntax is a quite peculiar (as few braces as possible), but may be
+customized.")
+ (license license:lppl)))
+
(define-public texlive-ydoc
(package
(name "texlive-ydoc")