summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:25:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:11 +0200
commitaa11f73eebc607938ab02e46564a3d3bc817ef87 (patch)
treec68fa120ce191cbe34fbdfe0e524c71c07bc380f /gnu
parentc288e1cc95bcc416c062db47c1af50cb5d6eb915 (diff)
gnu: Add texlive-texapi.
* gnu/packages/tex.scm (texlive-texapi): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bfdb11e96b..a633ddbc71 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15221,6 +15221,27 @@ This package is not intended to be used to automatically translate more than
a few words.")
(license (list license:lppl license:gpl1+))))
+(define-public texlive-texapi
+ (package
+ (name "texlive-texapi")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/texapi/" "tex/generic/texapi/")
+ (base32
+ "0ivg2a2pgl6bmb2242cjjcz7n9cs514dp1r8c89mva2zlm9l323j")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/texapi")
+ (synopsis "Macros to write format-independent packages")
+ (description
+ "Texapi provides utility macros to write format-independent (and -aware)
+packages. It is similar in spirit to the etoolbox, except that it isn't tied
+to LaTeX. The tools include engine and format detection, expansion control,
+command definition and manipulation, various testing macros, string
+operations, and highly customizable while and for loops.")
+ (license license:lppl)))
+
(define-public texlive-textpos
(package
(name "texlive-textpos")