summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:24:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:10 +0200
commitc288e1cc95bcc416c062db47c1af50cb5d6eb915 (patch)
treeb51776201ef4766cd708ba5b7199c8f16a6842ec /gnu
parent4133c2d38633c828d2e0f138dab5fd3bb1e0674a (diff)
gnu: Add texlive-gates.
* gnu/packages/tex.scm (texlive-gates): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ec6e5d7516..bfdb11e96b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14935,6 +14935,34 @@ numeric precision). @code{bezierplot} also finds special points such as
extreme points and inflection points and reduces the number of used points.")
(license license:lppl1.3c)))
+(define-public texlive-gates
+ (package
+ (name "texlive-gates")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/gates/" "tex/generic/gates/")
+ (base32
+ "0brcms8qbnsyiqnnqxyzqp12z1xpvfzb5hgh6kqm28904lr84i4g")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/gates")
+ (synopsis "Support for writing modular and customisable code")
+ (description
+ "The package provides the means of writing code in a modular fashion: big
+macros or functions are divided into small chunks (called gates) with names,
+which can be externally controlled (e.g., they can be disabled, subjected to
+conditionals, loops...) and/or augmented with new chunks. Thus complex code
+may easily be customised without having to rewrite it, or even understand its
+implementation: the behavior of existing gates can be modified, and new ones
+can be added, without endangering the whole design. This allows code to be
+hacked in ways the original authors might have never envisioned. The
+@code{gates} package is implemented independently for both TeX and Lua. The
+TeX implementation, running in any current environment, requires the
+@code{texapi} package, whereas the Lua version can be run with any Lua
+interpreter, not just LuaTeX.")
+ (license license:lppl)))
+
(define-public texlive-qrcode
(package
(name "texlive-qrcode")