summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:59:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:27 +0200
commitad8e83f82c645144f1ffaeb51fca6f4bfdb599d8 (patch)
tree2ea4046670d5944a45b37ae4e1fd79ca97b99fbb /gnu
parentd047f46ce23bfb8d27b05d07690d778a14e5046c (diff)
gnu: Add texlive-luaset.
* gnu/packages/tex.scm (texlive-luaset): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 36f7c6e979..ec483db7ba 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16822,6 +16822,29 @@ It is possible to get lists with or without multiple numbers. The random
generator will be initialized by the system time.")
(license license:lppl1.3+)))
+(define-public texlive-luaset
+ (package
+ (name "texlive-luaset")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/luaset/"
+ "tex/lualatex/luaset/")
+ (base32
+ "1xbr7m1fb71xnlc3p4lb2gz10i6bz6f4bbzyfcclggriq7bkv1iq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/luaset")
+ (synopsis "Set Operations inside LaTeX documents using Lua")
+ (description
+ "The @code{luaset} package is developed to define finite sets and perform
+operations on them inside LaTeX documents. There is no particular environment
+in the package for performing set operations. The package commands can be
+used in any environment (including the mathematics environment). It is
+written in Lua, and the @file{.tex} file is to be compiled with the LuaLaTeX
+engine.")
+ (license license:lppl1.3c)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")