summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:46:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:49 +0200
commitce9dcbb337a526f9c6fa0ac6c2d257898126da29 (patch)
tree40425042270acf38f9bb0af678e52c5431e62a90 /gnu
parent97c4a0c26fcc79fb2703dd79b32ac1e08f1f0609 (diff)
gnu: Add texlive-pst-pdf.
* gnu/packages/tex.scm (texlive-pst-pdf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3030f32295..7976b3d45c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33716,6 +33716,30 @@ such as boundary lubrication, elastohydrodynamic lubrication and hydrodynamic
lubrication.")
(license license:lppl)))
+(define-public texlive-pst-pdf
+ (package
+ (name "texlive-pst-pdf")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pst-pdf/" "scripts/pst-pdf/"
+ "source/latex/pst-pdf/" "tex/latex/pst-pdf/")
+ (base32
+ "1as5q9p6z9y3ps3hm8v8par18xmxmhrcxmknpl6rhjq0wbyjlj26")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "ps4pdf")))
+ (home-page "https://ctan.org/pkg/pst-pdf")
+ (synopsis "Make PDF versions of graphics by processing between runs")
+ (description
+ "The package @code{pst-pdf} simplifies the use of graphics from PSTricks
+and other PostScript code in PDF documents. As in building a bibliography
+with BibTeX, additional external programmes are invoked. In this case they
+are used to create a PDF file that will contain all the graphics material. In
+the final document these contents will be inserted instead of the original
+PostScript code.")
+ (license license:lppl1.2+)))
+
(define-public texlive-pst-pdgr
(package
(name "texlive-pst-pdgr")