summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-07-27 00:15:42 +0100
committerAndreas Enge <andreas@enge.fr>2023-08-08 09:36:59 +0200
commitdc3c9ddc0850c633aa9f194ec941fa529a308743 (patch)
tree3adf9db0772f7274e19e577209b2de9ed34a03f1 /gnu
parent296a1570926b2449c515ca3ce385103c436e058b (diff)
gnu: python-pyerfa: Use G-expressions.
* gnu/packages/astronomy.scm (python-pyerfa): Use G-expressions. [snippet]: Remove trailing #t. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a3d71c09af..556ba8c6a2 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3251,23 +3251,23 @@ exposures and high-level data products (mosaics, extracted spectra, etc.).")
(base32 "0f8zykzxjsiwv5ibdn5asla2ng2xl0xdkrcrrd61j31mb3xbnzyp"))
(modules '((guix build utils)))
(snippet
- '(begin
- ;; Remove bundled submodule library.
- (delete-file-recursively "liberfa")
- #t))))
+ #~(begin
+ ;; Remove bundled submodule library.
+ (delete-file-recursively "liberfa")))))
(build-system pyproject-build-system)
(arguments
- `(;; Disable only one failing test:
- ;; AttributeError: __warningregistry__
- #:test-flags '("-k" "not test_errwarn_reporting")
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'use-system-liberfa
- (lambda _
- (setenv "PYERFA_USE_SYSTEM_LIBERFA" "1")))
- (add-before 'check 'build-extensions
- (lambda _
- (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (list
+ ;; Disable only one failing test:
+ ;; AttributeError: __warningregistry__
+ #:test-flags #~(list "-k" "not test_errwarn_reporting")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'use-system-liberfa
+ (lambda _
+ (setenv "PYERFA_USE_SYSTEM_LIBERFA" "1")))
+ (add-before 'check 'build-extensions
+ (lambda _
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
(native-inputs
(list python-pytest-doctestplus python-pytest python-setuptools-scm))
(inputs