summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-06 22:49:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-06 23:16:56 +0300
commitdd23efe0208276ccf5d6063a81bd25ba438e8317 (patch)
tree8f64de4b24b69def4956fde5f07a96cb273a1360 /gnu
parentd967ffb367bfbc1600ff6da179fe96b6f5c5c60c (diff)
gnu: proteinortho: Update to 6.3.2.
* gnu/packages/bioinformatics.scm (proteinortho): Update to 6.3.2. [source]: Adjust snippet to also delete lapack source tarball. [arguments]: Rewrite using g-expressions. Add flag to run tests sequentially. Adjust make-flags for cross-compiling and to set PREFIX. Delete 'configure and custom 'configure phase. Remove trailing #t from phases. Change-Id: I40249e5ac92c26223119b81b4677c08d5ab230e6
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm61
1 files changed, 28 insertions, 33 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 781f298e62..dcb3896c6b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8984,7 +8984,7 @@ predicts the locations of structural units in the sequences.")
(define-public proteinortho
(package
(name "proteinortho")
- (version "6.0.14")
+ (version "6.3.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -8993,45 +8993,40 @@ predicts the locations of structural units in the sequences.")
(file-name (git-file-name name version))
(sha256
(base32
- "0pmy617zy2z2w6hjqxjhf3rzikf5n3mpia80ysq8233vfr7wrzff"))
+ "0p8iaxq193fh67hw3cydvdah1vz1c3f18227gj1mhkww0ms7g6xa"))
(modules '((guix build utils)))
(snippet
'(begin
- ;; remove pre-built scripts
+ ;; Remove pre-built scripts and source tarballs.
(delete-file-recursively "src/BUILD/")
- #t))))
+ (delete-file "src/lapack-3.8.0.tar.gz")))))
(build-system gnu-build-system)
(arguments
- `(#:test-target "test"
- #:make-flags '("CC=gcc")
+ (list
+ #:test-target "test"
+ #:parallel-tests? #f
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "CXX=" #$(cxx-for-target))
+ (string-append "PREFIX=" #$output)
+ (string-append "INSTALLDIR=" #$output "/bin"))
#:phases
- (modify-phases %standard-phases
- (replace 'configure
- ;; There is no configure script, so we modify the Makefile directly.
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile"
- (("INSTALLDIR=.*")
- (string-append
- "INSTALLDIR=" (assoc-ref outputs "out") "/bin\n"))
- (("-llapack -lblas")
- "-lopenblas"))
- #t))
- (add-before 'install 'make-install-directory
- ;; The install directory is not created during 'make install'.
- (lambda* (#:key outputs #:allow-other-keys)
- (mkdir-p (string-append (assoc-ref outputs "out") "/bin"))
- #t))
- (add-after 'install 'wrap-programs
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((path (getenv "PATH"))
- (out (assoc-ref outputs "out"))
- (guile (search-input-file inputs "bin/guile")))
- (for-each (lambda (script)
- (wrap-script script #:guile guile
- `("PATH" ":" prefix (,path))))
- (cons (string-append out "/bin/proteinortho")
- (find-files out "\\.(pl|py)$"))))
- #t)))))
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'make-install-directory
+ ;; The install directory is not created during 'make install'.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (mkdir-p (string-append (assoc-ref outputs "out") "/bin"))))
+ (add-after 'install 'wrap-programs
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((path (getenv "PATH"))
+ (out (assoc-ref outputs "out"))
+ (guile (search-input-file inputs "bin/guile")))
+ (for-each (lambda (script)
+ (wrap-script script #:guile guile
+ `("PATH" ":" prefix (,path))))
+ (cons (string-append out "/bin/proteinortho")
+ (find-files out "\\.(pl|py)$")))))))))
(inputs
`(("guile" ,guile-3.0) ; for wrap-script
("diamond" ,diamond)