summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 17:21:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:29 +0200
commite1260179f9d6f220a3f1d26feac8297891ae7758 (patch)
tree01ce60bce892ada8083d690812fe66d0ce14a6bb /gnu
parentb1dc3313f4b1ebeca909477452acb2f377ef9b05 (diff)
gnu: Add texlive-york-thesis.
* gnu/packages/tex.scm (texlive-york-thesis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3ade2ffd57..9b50e65113 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -32558,6 +32558,27 @@ and a LaTeX package for using them.")
Original Metafont files for @code{yinit} are in the @code{yinit} package.")
(license license:public-domain)))
+(define-public texlive-york-thesis
+ (package
+ (name "texlive-york-thesis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/york-thesis/"
+ "source/latex/york-thesis/"
+ "tex/latex/york-thesis/")
+ (base32
+ "0wcl1zqmif2chramah8zmbgp5axbhlnjiygl7kgqnwqw5ajxkw4y")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/york-thesis")
+ (synopsis "Thesis class file for York University, Toronto")
+ (description
+ "York Graduate Studies has again changed the requirements for theses and
+dissertations. The established @code{york-thesis} class file now implements
+the changes made in Spring 2005.")
+ (license license:lppl1.3+)))
+
(define-public texlive-youngtab
(package
(name "texlive-youngtab")