summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-09-07 23:32:23 +0100
committerChristopher Baines <mail@cbaines.net>2023-09-27 12:07:19 +0100
commite211419e0ae1c6c9130af4796ac2e6e49088d518 (patch)
tree6b2652c050dde1fee976d815c9ad23a2951f20de /gnu
parent9bf19a302ba10d47eafed054a066fbe30a3f2ec0 (diff)
gnu: python-roman-datamodels: Update to 0.17.1.
* gnu/packages/astronomy.scm (python-roman-datamodels): Update to 0.17.1. [arguments]{phases}: Add 'set-env phase to pass tests. [native-inputs]: Remove python-pytest-openfiles. Add python-pytest-env. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a402c63e9f..d1b34def8f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3835,13 +3835,13 @@ Grace Roman Space Telescope.")
(define-public python-roman-datamodels
(package
(name "python-roman-datamodels")
- (version "0.15.0")
+ (version "0.17.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "roman_datamodels" version))
(sha256
(base32
- "0frhm1cqqd8934yizhm4fy78y38q2w9ncm4rv1n74hfypkyis4ap"))))
+ "1y12cp8172i4a314gmhpi86jw6pfylz1adh0rzr5zqmvd3mrjqlj"))))
(build-system pyproject-build-system)
(arguments
;; XXX: Check how to make all tests enabled, probably some more inner
@@ -3850,7 +3850,12 @@ Grace Roman Space Telescope.")
(list #:test-flags #~(list "-k"
(string-append "not test_will_validate"
" and not test_will_strict_validate"
- " and not test_nuke_validation"))))
+ " and not test_nuke_validation"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-env
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
(propagated-inputs (list python-asdf
python-asdf-astropy
python-asdf-standard
@@ -3859,8 +3864,10 @@ Grace Roman Space Telescope.")
python-numpy
python-psutil
python-rad))
- (native-inputs (list python-pytest python-pytest-doctestplus
- python-pytest-openfiles python-semantic-version
+ (native-inputs (list python-pytest
+ python-pytest-doctestplus
+ python-pytest-env
+ python-semantic-version
python-setuptools-scm))
(home-page "https://github.com/spacetelescope/roman_datamodels")
(synopsis "Roman Datamodels Support")