summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 17:19:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:28 +0200
commite5041de05380c3bd9a22b139e87ce3af81a99a13 (patch)
tree81b4edc95ada6f882d4e1fe3467f470ae9cf057d /gnu
parent5d5f04ca0b86b8a74da7e05f49f75b38d1771621 (diff)
gnu: Add texlive-xduts.
* gnu/packages/tex.scm (texlive-xduts): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 400e460169..fe207a2f3e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -32161,6 +32161,29 @@ levels of degrees from bachelor to doctor, including both academic master and
professional master.")
(license license:lppl1.3+)))
+(define-public texlive-xduts
+ (package
+ (name "texlive-xduts")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/xelatex/xduts/" "source/xelatex/xduts/"
+ "tex/xelatex/xduts/")
+ (base32
+ "17zd5i4vxpg2n7w9449q754i2k280jjm18pfl6d8b6r1adv5hy4c")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (native-inputs (list texlive-ctex))
+ (home-page "https://ctan.org/pkg/xduts")
+ (synopsis "Xidian University TeX suite")
+ (description
+ "XDUTS is designed to help Xidian University students use LaTeX
+typesetting efficiently. XDUTS contains a font configuration package that
+meets the school's requirements and can be applied to any document class. In
+addition, there are thesis and thesis proposal templates for both
+undergraduate and postgraduate that meet the school's requirements.")
+ (license license:lppl1.3c)))
+
(define-public texlive-xecjk
(package
(name "texlive-xecjk")