summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:29:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:41 +0200
commitfc22618399b28d9b2dad9aaa57b02bfe5197d873 (patch)
treee47769db24762cf4c7c510a21d09bfcbeb6fcf53 /gnu
parentcebfc78ae24eaa835e3a5df51e8c9fffdedfef76 (diff)
gnu: Add texlive-pst-osci.
* gnu/packages/tex.scm (texlive-pst-osci): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5a21896fc4..abd6b32f31 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33650,6 +33650,29 @@ realistic raytraced beam paths are also possible.")
refractive optics diagrams.")
(license license:lppl)))
+(define-public texlive-pst-osci
+ (package
+ (name "texlive-pst-osci")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-osci/"
+ "tex/generic/pst-osci/"
+ "tex/latex/pst-osci/")
+ (base32
+ "0h7wnpm26z8v904yj0wvadrjsh3j5fsn73ihilxhb4zd88zqib99")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-osci")
+ (synopsis "Oscgons with PSTricks")
+ (description
+ "This PSTricks package enables you to produce oscilloscope screen shots.
+Three channels can be used to represent the most common signals (damped or
+not): namely sinusoidal, rectangular, triangular, dog's tooth (left and right
+oriented). The third channel allows you to add, to subtract or to multiply
+the two other signals. Lissajous diagrams (XY-mode) can also be obtained.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")