summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2023-10-07 11:21:28 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-12-28 23:48:22 +0100
commit13114fa36da9cac4d14b7fc559ec6731d98cb443 (patch)
tree9ad4819b8041ab24d0a5648ca29bd910b7cf17a3
parent62d1c7ab6b2bda4d301e0f10d290d9250ac92d10 (diff)
nongnu: anytype: Avoid manually unpacking .deb file.
* nongnu/packages/productivity.scm (anytype)[phases] Drop 'unpack-deb phase; [native-inputs]: drop tar. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
-rw-r--r--nongnu/packages/productivity.scm9
1 files changed, 0 insertions, 9 deletions
diff --git a/nongnu/packages/productivity.scm b/nongnu/packages/productivity.scm
index d063288..89ab0bc 100644
--- a/nongnu/packages/productivity.scm
+++ b/nongnu/packages/productivity.scm
@@ -58,14 +58,6 @@
("usr/share/" "/share"))
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'unpack-deb
- (lambda* (#:key inputs #:allow-other-keys)
- (invoke "ar" "x" #$source)
- (invoke "rm" "-v" "control.tar.gz"
- "debian-binary"
- (string-append "anytype-" #$version ".deb"))
- (invoke "tar" "xvf" "data.tar.xz")
- (invoke "rm" "-vrf" "data.tar.xz")))
(add-before 'install 'patch-assets
(lambda _
(let* ((bin (string-append #$output "/bin"))
@@ -86,7 +78,6 @@
(symlink target exe)
(wrap-program exe
`("LD_LIBRARY_PATH" = (,share)))))))))
- (native-inputs (list tar))
(inputs
(list bzip2
flac