summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2023-06-07 11:19:31 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-06-07 11:19:31 +0200
commit27a471f56b93e79403d52888d6a485149f781b56 (patch)
tree2810b496b18c4641e822c9949df829748daf8e8a
parent550ab7e8bec3f7520155c0ca1a3be98c388d6e66 (diff)
nongnu: firefox-esr: Update to 102.12.0esr [security fixes].
Fixes CVE-2023-34414 and CVE-2023-34416. * nongnu/packages/mozilla.scm (firefox-esr): Update to 102.12.0esr.
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index e1d3a21..50cb26a 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -95,19 +95,19 @@
;; Update this id with every firefox update to it's release date.
;; It's used for cache validation and therefor can lead to strange bugs.
-(define %firefox-esr-build-id "20230509000000")
+(define %firefox-esr-build-id "20230606000000")
(define-public firefox-esr
(package
(name "firefox-esr")
- (version "102.11.0esr")
+ (version "102.12.0esr")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "0cyfij00i9m1pwwyfhiq2qasbfr2ykdwziqykj8878kyjvkj1wg7"))))
+ (base32 "189irpd8xkwh3qixbbcmn5jblx7jz80rilcq8ihaawpmdh76safp"))))
(build-system gnu-build-system)
(arguments
(list