summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ziltener <dziltener@lyrion.ch>2024-03-22 21:29:48 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2024-03-22 21:46:19 -0400
commit79939d562b33fe8ca8c7cee563cfed69a98656c0 (patch)
tree3cfac55b5012af679f7592e082bde793b305ce5c
parentc245d8f80b4cd2b33e88c6b4b5d983f99689f4c3 (diff)
nongnu: Add babashka.
* nongnu/packages/clojure.scm (babashka): New variable. Signed-off-by: John Kehayias <john.kehayias@protonmail.com> Co-authored-by: John Kehayias <john.kehayias@protonmail.com>
-rw-r--r--nongnu/packages/clojure.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/nongnu/packages/clojure.scm b/nongnu/packages/clojure.scm
index a124767..1e9df62 100644
--- a/nongnu/packages/clojure.scm
+++ b/nongnu/packages/clojure.scm
@@ -147,3 +147,35 @@ Clojure/Clojurescript to all editors and programatically via its CLI and API.
It aims to work alongside you to help you navigate, identify and fix errors,
perform refactors and more.")
(license license:expat)))
+
+(define-public babashka
+ (package
+ (name "babashka")
+ (version "1.3.189")
+ (source (origin
+ (method url-fetch/tarbomb)
+ (uri (string-append "https://github.com/babashka/babashka"
+ "/releases/download/v" version "/babashka-"
+ version "-linux-amd64.tar.gz"))
+ (sha256
+ (base32
+ "1gzra3y5iljjqi4rj1qxr3yniqla3qnhv881gkzrp788fwsvlmwv"))))
+ (build-system binary-build-system)
+ (arguments
+ `(#:patchelf-plan
+ '(("bb" ("gcc" "zlib")))
+ #:install-plan
+ '(("./bb" "/bin/"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chmod
+ (lambda _
+ (chmod "bb" #o755))))))
+ (inputs (list `(,gcc "lib") zlib))
+ (supported-systems '("x86_64-linux"))
+ (home-page "https://github.com/babashka/babashka")
+ (synopsis "Native, fast starting Clojure interpreter for scripting")
+ (description "Babashka is a native Clojure interpreter for scripting with
+fast startup. Its main goal is to leverage Clojure in places where you would
+be using bash otherwise.")
+ (license license:epl1.0)))