summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2024-01-31 17:55:06 +0100
committerJohn Kehayias <john.kehayias@protonmail.com>2024-01-31 15:48:57 -0500
commitae314a6eaa8c07e728083eec066f1685decd2a91 (patch)
treeb12fc4b4f80e4cf3c05065a87f995936738eec52
parentf9ed62f37d237fbb854554bd1d643fd3e1d05a2a (diff)
nongnu: anytype: Update to 0.38.
* nongnu/packages/productivity.scm (anytype): Update to 0.38. [arguments]: Add strip-python phase. Signed-off-by: John Kehayias <john.kehayias@protonmail.com> Co-authored-by: John Kehayias <john.kehayias@protonmail.com>
-rw-r--r--nongnu/packages/productivity.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/nongnu/packages/productivity.scm b/nongnu/packages/productivity.scm
index d0b7f37..5ccabb7 100644
--- a/nongnu/packages/productivity.scm
+++ b/nongnu/packages/productivity.scm
@@ -24,17 +24,17 @@
(define-public anytype
(package
(name "anytype")
- (version "0.37.3")
+ (version "0.38")
(source
(origin
(method url-fetch)
(uri
(string-append "https://download.anytype.io?action=download"
- "&key=desktop&id=142685264"))
+ "&key=desktop&id=148487107"))
(file-name (string-append "anytype-" version ".deb"))
(sha256
(base32
- "197v4dsn21yfi9dhcrqdznz3vfzicd79fc4abbpifacgb4fxcxq8"))))
+ "1xc57ppk3l16mq2a53scf79m8hx43x21kac96ws66awlkz14swc7"))))
(build-system chromium-binary-build-system)
(arguments
(list
@@ -58,6 +58,11 @@
("usr/share/" "/share"))
#:phases
#~(modify-phases %standard-phases
+ (add-after 'binary-unpack 'strip-python
+ (lambda _
+ (delete-file
+ (string-append "opt/Anytype/resources/app.asar.unpacked/"
+ "node_modules/keytar/build/node_gyp_bins/python3"))))
(add-before 'install 'patch-assets
(lambda _
(let* ((bin (string-append #$output "/bin"))