summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-01-23 16:25:52 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2024-01-23 18:13:39 +0100
commitd0a8b135d3c75dca774e55e15b4671dcf5965cd1 (patch)
tree466029e75c23c02b45900e3dbd00ba903514645e
parent94f27641b1ff3a9816d7812ad0e52a77105198d0 (diff)
nongnu: firefox: Update to 122.0 [security fixes].
Fixes CVE-2024-0741, CVE-2024-0742, CVE-2024-0743, CVE-2024-0744, CVE-2024-0745, CVE-2024-0746, CVE-2024-0747, CVE-2024-0748, CVE-2024-0749, CVE-2024-0750, CVE-2024-0751, CVE-2024-0752, CVE-2024-0753, CVE-2024-0754, CVE-2024-0755. * nongnu/packages/mozilla.scm (firefox): Update to 122.0. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
-rw-r--r--nongnu/packages/mozilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index e0a8ca3..c40c604 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -532,20 +532,20 @@ MOZ_ENABLE_WAYLAND=1 exec ~a $@\n"
;; Update this id with every firefox update to its release date.
;; It's used for cache validation and therefore can lead to strange bugs.
-(define %firefox-build-id "20240109024134")
+(define %firefox-build-id "20240122142651")
(define-public firefox
(package
(inherit firefox-esr)
(name "firefox")
- (version "121.0.1")
+ (version "122.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "1kj97vk8322r7bp7k0laly8bsvwmrn6rsrgldry9msza05p2395k"))))
+ (base32 "1hyylp60sqswyig5w422rq7sn8hhbg49j1dmq3j6ay8l1sliaj5q"))))
(arguments
(substitute-keyword-arguments (package-arguments firefox-esr)
((#:phases phases)