summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2024-01-06 15:09:03 +0100
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2024-01-07 16:03:21 +0100
commitf325d88cb6b47aea4d5bccb868bb411c98906486 (patch)
tree0a6a2b693aa2468866f95b650d3de26ff876520a
parent1f91ecd3c06ac3275490311ec79bb8f361e9d963 (diff)
nongnu: anytype: Update to 0.37.3.
* nongnu/packages/productivity.scm (anytype): Update to 0.37.3; [arguments]<phases>: avoid hardcoding the icon path in anytype.desktop. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
-rw-r--r--nongnu/packages/productivity.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/nongnu/packages/productivity.scm b/nongnu/packages/productivity.scm
index 89ab0bc..d0b7f37 100644
--- a/nongnu/packages/productivity.scm
+++ b/nongnu/packages/productivity.scm
@@ -24,17 +24,17 @@
(define-public anytype
(package
(name "anytype")
- (version "0.36.0")
+ (version "0.37.3")
(source
(origin
(method url-fetch)
(uri
(string-append "https://download.anytype.io?action=download"
- "&key=desktop&id=136705969"))
+ "&key=desktop&id=142685264"))
(file-name (string-append "anytype-" version ".deb"))
(sha256
(base32
- "17cs4w3k7nmjav873wwzpxb2dz4mp2zgkpz1karp3x2mxan0x2i3"))))
+ "197v4dsn21yfi9dhcrqdznz3vfzicd79fc4abbpifacgb4fxcxq8"))))
(build-system chromium-binary-build-system)
(arguments
(list
@@ -61,12 +61,10 @@
(add-before 'install 'patch-assets
(lambda _
(let* ((bin (string-append #$output "/bin"))
- (icon (string-append #$output "/share/icons/hicolor/0x0/apps/anytype.png"))
(usr/share "./usr/share")
(old-exe "/opt/Anytype/anytype")
(exe (string-append bin "/anytype")))
(substitute* (string-append usr/share "/applications/anytype.desktop")
- (("^Icon=anytype") (string-append "Icon=" icon))
(((string-append "^Exec=" old-exe)) (string-append "Exec=" exe))))))
(add-before 'install-wrapper 'symlink-entrypoint
(lambda _