summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorTimo Wilken <guix@twilken.net>2023-12-15 21:04:24 +0100
committerJohn Kehayias <john.kehayias@protonmail.com>2024-01-03 17:24:44 -0500
commit07b884a7b1f019f427e4d17e0094326069152f40 (patch)
treee3080767f34f391e42cfe0b576d2915e77ef4006 /nongnu
parent8956906f6bed6709e71f0c26ed6a3620f40dc487 (diff)
nongnu: steam-nvidia: Fix launching .desktop files.
Steam installs .desktop files that refer to an executable called `steam'. Installing steam-nvidia as the `steam-nvidia' executable breaks this, which means Steam cannot be launched from its desktop icon. This also applies to .desktop files for individual games generated by Steam, when they are copied from `<ngc-sandbox-home>/.local/share/applications/'. Fix this by always installing Steam's wrapper executable as `steam'. We add a new field using "binary" to keep things shorter. This has the downside that the `steam' and `steam-nvidia' packages cannot be installed in the same profile, but likely people wouldn't want to do this anyway. Fixes #294. * nongnu/packages/steam-client.scm (steam-nvidia-container)[binary-name]: Specify for compatibility with .desktop files. * nonguix/multiarch-container.scm (<nonguix-container>)[binary-name, ngc-binary-name]: New field and accessor. (nonguix-container->package): Use it to set correct executable name. (make-internal-script): Use it in message. Co-authored-by: John Kehayias <john.kehayias@protonmail.com> Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/steam-client.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/nongnu/packages/steam-client.scm b/nongnu/packages/steam-client.scm
index 2f313c7..c8ff950 100644
--- a/nongnu/packages/steam-client.scm
+++ b/nongnu/packages/steam-client.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2023 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2023 Elijah Malaby
+;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
(define-module (nongnu packages steam-client)
#:use-module ((guix licenses) #:prefix license:)
@@ -200,6 +201,8 @@ all games will be installed.")))
(nonguix-container
(inherit steam-container)
(name "steam-nvidia")
+ ;; Steam's .desktop files expect a "steam" executable, so provide that.
+ (binary-name "steam")
(union64 (replace-mesa (ngc-union64 steam-container)))
(union32 (replace-mesa (ngc-union32 steam-container)))))