summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-03-16 07:32:38 +0800
committerJohn Kehayias <john.kehayias@protonmail.com>2024-04-14 16:00:00 -0400
commit9c70cf49c8734b3807cc92b2e5a123b3800efd7f (patch)
treefe01387f634bc5575d08e70994fd9a93775bc23a /nongnu
parent393abd05a295401303defa6c368766d99d0946d8 (diff)
nongnu: make-linux-xanmod: Remove unnecessary option overrides.
Guix can identify builtin modules when building the initrd now. * nongnu/packages/linux.scm (make-linux-xanmod)[arguments]<#:phases>: Don't override CONFIG_CRYPTO_XTS and CONFIG_VIRTIO_CONSOLE in 'add-xanmod-defconfig. Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/linux.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 9ae113d..d0b9edc 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -255,9 +255,7 @@ on hardware which requires nonfree software to function."))))
(append %default-extra-linux-options
;; NOTE: These are configs expected by Guix
;; but missing from XanMod defconfig.
- '(("CONFIG_BLK_DEV_NVME" . #t)
- ("CONFIG_CRYPTO_XTS" . m)
- ("CONFIG_VIRTIO_CONSOLE" . m))))))
+ '(("CONFIG_BLK_DEV_NVME" . #t))))))
(display extra-configuration port)
(close-port port))
(invoke "make" "oldconfig")