summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--nongnu/packages/editors.scm35
-rw-r--r--nongnu/packages/messaging.scm4
-rw-r--r--nongnu/packages/mozilla.scm6
-rw-r--r--nongnu/packages/productivity.scm8
-rw-r--r--nongnu/packages/video.scm74
5 files changed, 99 insertions, 28 deletions
diff --git a/nongnu/packages/editors.scm b/nongnu/packages/editors.scm
index d07bf1d..114fe85 100644
--- a/nongnu/packages/editors.scm
+++ b/nongnu/packages/editors.scm
@@ -1,5 +1,5 @@
;;; SPDX-License-Identifier: GPL-3.0-or-later
-;;; Copyright © 2023 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2023, 2024 Giacomo Leidi <goodoldpaul@autistici.org>
(define-module (nongnu packages editors)
#:use-module (gnu packages base)
@@ -14,20 +14,27 @@
(define-public vscodium
(package
(name "vscodium")
- (version "1.87.0.24060")
+ (version "1.88.1.24104")
(source
- (origin
- (method url-fetch)
- (uri
- (let ((arch (match (or (%current-target-system) (%current-system))
- ("aarch64-linux" "arm64")
- ("armhf-linux" "armhf")
- (_ "x64"))))
- (string-append
- "https://github.com/VSCodium/vscodium/releases/download/" version
- "/VSCodium-linux-" arch "-" version ".tar.gz")))
- (sha256
- (base32 "1lw7j8h0i96mg8si8dmi55ldbz5j63zb93qf1g59siavx84f1zpd"))))
+ (let ((arch (match (or (%current-target-system) (%current-system))
+ ("aarch64-linux" "arm64")
+ ("armhf-linux" "armhf")
+ (_ "x64")))
+ (hash (match (or (%current-target-system) (%current-system))
+ ("aarch64-linux"
+ "0412222l9r81f3aa3zlzrg42hzslvvck5kds7zrmpssjrd41jxfh")
+ ("armhf-linux"
+ "1sblaigrxscx4l1kln1zxzm5da5lr50y1k6qb4igq6wxbdx55iay")
+ (_
+ "1n3gb12asid2qwwzf9fj974ws9n7has9l23ni8jscx9cp63l5rbl"))))
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://github.com/VSCodium/vscodium/releases/download/" version
+ "/VSCodium-linux-" arch "-" version ".tar.gz"))
+ (sha256
+ (base32 hash)))))
(build-system chromium-binary-build-system)
(arguments
(list #:validate-runpath? #f ; TODO: fails on wrapped binary and included other files
diff --git a/nongnu/packages/messaging.scm b/nongnu/packages/messaging.scm
index aeb8f3e..e300915 100644
--- a/nongnu/packages/messaging.scm
+++ b/nongnu/packages/messaging.scm
@@ -90,7 +90,7 @@ its core.")
(define-public signal-desktop
(package
(name "signal-desktop")
- (version "7.3.0")
+ (version "7.4.0")
(source
(origin
(method url-fetch)
@@ -99,7 +99,7 @@ its core.")
"https://updates.signal.org/desktop/apt/pool/s/" name "/" name "_" version
"_amd64.deb"))
(sha256
- (base32 "1gkcfh94l5nj8p3jk7g80jqq11fb8igi4wm84g67a9qi8n56wcrc"))))
+ (base32 "069k7kcg8h16q0mm1bqdf7x66qji653apgwhnb52kdqsfzr1ibzm"))))
(supported-systems '("x86_64-linux"))
(build-system chromium-binary-build-system)
(arguments
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 7a51866..0588ad6 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -532,20 +532,20 @@ MOZ_ENABLE_WAYLAND=1 exec ~a $@\n"
;; Update this id with every firefox update to its release date.
;; It's used for cache validation and therefore can lead to strange bugs.
-(define %firefox-build-id "20240422125740")
+(define %firefox-build-id "20240429124342")
(define-public firefox
(package
(inherit firefox-esr)
(name "firefox")
- (version "125.0.2")
+ (version "125.0.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://archive.mozilla.org/pub/firefox/releases/"
version "/source/firefox-" version ".source.tar.xz"))
(sha256
- (base32 "16gpd6n52lshvkkha41z7xicggj64dw0qhr5gd07bcxsc4rmdl39"))))
+ (base32 "05jnpnc0qym08f7rlapjm36g729445k3nba2rvf4a0sabsw6c726"))))
(arguments
(substitute-keyword-arguments (package-arguments firefox-esr)
((#:phases phases)
diff --git a/nongnu/packages/productivity.scm b/nongnu/packages/productivity.scm
index 1065399..e6158f9 100644
--- a/nongnu/packages/productivity.scm
+++ b/nongnu/packages/productivity.scm
@@ -24,7 +24,7 @@
(define-public anytype
(package
(name "anytype")
- (version "0.39.0")
+ (version "0.40.0")
(source
(origin
(method url-fetch)
@@ -34,7 +34,7 @@
(file-name (string-append "anytype-" version ".deb"))
(sha256
(base32
- "10y037qwm6k28min2sgpshrlpirc1p0zn3b4syxrrz494x5g2ivi"))))
+ "01q6dzks8hjb2whdkj7c816fji7rn5dpx00ss7rxgvxb5rdz19gr"))))
(build-system chromium-binary-build-system)
(arguments
(list
@@ -52,8 +52,8 @@
"libGLESv2.so"
"libvk_swiftshader.so"
"libvulkan.so.1"
- "resources/app.asar.unpacked/dist/nativeMessagingHost"
- "resources/app.asar.unpacked/node_modules/keytar/build/Release/keytar.node"))
+ "resources/app.asar.unpacked/node_modules/keytar/build/Release/keytar.node"
+ "resources/app.asar.unpacked/node_modules/keytar/build/Release/obj.target/keytar.node"))
#:install-plan
#~'(("opt/" "/share")
("usr/share/" "/share"))
diff --git a/nongnu/packages/video.scm b/nongnu/packages/video.scm
index 4c6a4b0..e5af3a1 100644
--- a/nongnu/packages/video.scm
+++ b/nongnu/packages/video.scm
@@ -1,5 +1,6 @@
;;; SPDX-License-Identifier: GPL-3.0-or-later
;;; Copyright © 2022 Jelle Licht <jlicht@fsfe.org>
+;;; Copyright © 2024 Oleg Pykhalov <go.wigust@gmail.com>
(define-module (nongnu packages video)
#:use-module (gnu packages pkg-config)
@@ -10,12 +11,13 @@
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix utils)
- #:use-module ((guix licenses) #:prefix license:))
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (nongnu packages chromium))
(define-public gmmlib
(package
(name "gmmlib")
- (version "22.3.15")
+ (version "22.3.19")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -24,7 +26,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0qmdprqarqdz8z6s1av2vmd7ma5yaswxkxzdjci57fgyylqkjlri"))))
+ "0p3wp6xcvpb4jzw4fsf6554qy91iblmq9y50ph3iy29m19q6nznb"))))
(build-system cmake-build-system)
(arguments
;; Tests are run as part of the normal build step
@@ -40,7 +42,7 @@ for VAAPI.")
(define-public intel-media-driver
(package
(name "intel-media-driver")
- (version "23.4.3")
+ (version "24.1.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -49,7 +51,7 @@ for VAAPI.")
(file-name (git-file-name name version))
(sha256
(base32
- "0rgjakygfzy6d3jz38nnjvcvqyjnwz2b4vfh1ifqfcm3bw56fmr9"))))
+ "1jm4imld48scj0j499wq5zbdjv4gg7hg2sawljqnjvy09dmp09bs"))))
(build-system cmake-build-system)
(inputs (list libva gmmlib))
(native-inputs (list pkg-config))
@@ -92,3 +94,65 @@ graphics hardware.")
(package-description intel-media-driver)
" This build of intel-media-driver includes nonfree blobs to fully enable the
video decode capabilities of supported Intel GPUs."))))
+
+(define-public obs-with-cef
+ (package
+ (inherit obs)
+ (name "obs-with-cef")
+ (inputs
+ (append (package-inputs obs)
+ `(("chromium-embedded-framework" ,chromium-embedded-framework))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments obs)
+ ((#:configure-flags flags)
+ #~(append #$flags
+ '("-DBUILD_BROWSER=ON"
+ "-DCEF_ROOT_DIR=../source/cef")))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-before 'configure 'add-cef
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((chromium-embedded-framework
+ #$(this-package-input "chromium-embedded-framework")))
+ (mkdir-p "cef/Release")
+ (mkdir-p "cef/Resources")
+ (for-each (lambda (file)
+ (symlink file (string-append "cef/Release/"
+ (basename file)))
+ (symlink file (string-append "cef/Resources/"
+ (basename file))))
+ (filter
+ (lambda (file)
+ (not (string= (basename (dirname file))
+ "locales")))
+ (find-files
+ (string-append chromium-embedded-framework
+ "/share/cef"))))
+ (symlink (string-append chromium-embedded-framework
+ "/lib/libcef.so")
+ "cef/Release/libcef.so")
+ (mkdir-p "cef/libcef_dll_wrapper")
+ (symlink (string-append chromium-embedded-framework
+ "/lib/libcef_dll_wrapper.a")
+ "cef/libcef_dll_wrapper/libcef_dll_wrapper.a")
+ (symlink (string-append chromium-embedded-framework
+ "/include")
+ "cef/include"))))
+ (add-after 'install 'symlink-obs-browser
+ ;; Required for lib/obs-plugins/obs-browser.so file.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (symlink
+ (string-append #$output
+ "/lib/libobs-frontend-api.so.0")
+ (string-append #$output
+ "/lib/obs-plugins/libobs-frontend-api.so.0"))
+ (symlink
+ (string-append #$output
+ "/lib/libobs.so.0")
+ (string-append #$output
+ "/lib/obs-plugins/libobs.so.0"))))))))
+ (description
+ (string-append
+ (package-description obs)
+ " This build of OBS includes embeded Chromium-based browser to enable
+Browser source."))))