summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--nongnu/packages/mozilla.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/nongnu/packages/mozilla.scm b/nongnu/packages/mozilla.scm
index 117a2e2..0ce17ee 100644
--- a/nongnu/packages/mozilla.scm
+++ b/nongnu/packages/mozilla.scm
@@ -278,10 +278,13 @@
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(lib (string-append out "/lib"))
- (ld-libs (map (lambda (x)
- (string-append (assoc-ref inputs x)
- "/lib"))
- '("pulseaudio" "mesa")))
+ (ld-libs
+ (map (lambda (x)
+ (string-append (assoc-ref inputs x)
+ "/lib"))
+ '("pulseaudio" "mesa"
+ ;; For the integration of native notifications
+ "libnotify")))
(gtk-share (string-append (assoc-ref inputs "gtk+")
"/share")))
(wrap-program (car (find-files lib "^firefox$"))
@@ -347,6 +350,7 @@
("libffi" ,libffi)
("libgnome" ,libgnome)
("libjpeg-turbo" ,libjpeg-turbo)
+ ("libnotify" ,libnotify)
;; ("libpng-apng" ,libpng-apng)
("libvpx" ,libvpx)
("libxcomposite" ,libxcomposite)
@@ -407,7 +411,9 @@ the official icon and the name \"firefox\".")
(ld-libs (map (lambda (x)
(string-append (assoc-ref inputs x)
"/lib"))
- '("pulseaudio" "mesa")))
+ '("pulseaudio" "mesa"
+ ;; For the integration of native notifications
+ "libnotify")))
(gtk-share (string-append (assoc-ref inputs "gtk+")
"/share")))
(wrap-program (car (find-files lib "^firefox$"))