summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/linux.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 0094b1c..baf3760 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -122,7 +122,12 @@ on hardware which requires nonfree software to function."))))
(corrupt-linux linux-libre-4.19))
(define-public linux-4.14
- (corrupt-linux linux-libre-4.14))
+ (corrupt-linux linux-libre-4.14
+ #:configs
+ '("# CONFIG_GCC_PLUGIN_CYC_COMPLEXITY is not set"
+ "# CONFIG_GCC_PLUGIN_LATENT_ENTROPY is not set"
+ "# CONFIG_GCC_PLUGIN_STRUCTLEAK is not set"
+ "# CONFIG_GCC_PLUGIN_RANDSTRUCT is not set")))
(define-public linux linux-6.6)
;; linux-lts points to the *newest* released long-term support version.