summaryrefslogtreecommitdiff
path: root/nongnu
diff options
context:
space:
mode:
authorDariqq <6424921-Dariqq@users.noreply.gitlab.com>2023-12-27 16:44:06 +0000
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2023-12-28 14:56:11 +0100
commit181e3acdf6d619d79945ec7d66ac65ad1d4a8f1a (patch)
treef7c261dee068e504cdf6f45306538c02e72c0c40 /nongnu
parent71a53faf2e1925a309b480f17e5b836740ce54bc (diff)
nongnu: linux-4.14: Disable gcc plugins.
* nongnu/packages/linux.scm (linux-4.14): Add additonal config options. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Diffstat (limited to 'nongnu')
-rw-r--r--nongnu/packages/linux.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 0094b1c..baf3760 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -122,7 +122,12 @@ on hardware which requires nonfree software to function."))))
(corrupt-linux linux-libre-4.19))
(define-public linux-4.14
- (corrupt-linux linux-libre-4.14))
+ (corrupt-linux linux-libre-4.14
+ #:configs
+ '("# CONFIG_GCC_PLUGIN_CYC_COMPLEXITY is not set"
+ "# CONFIG_GCC_PLUGIN_LATENT_ENTROPY is not set"
+ "# CONFIG_GCC_PLUGIN_STRUCTLEAK is not set"
+ "# CONFIG_GCC_PLUGIN_RANDSTRUCT is not set")))
(define-public linux linux-6.6)
;; linux-lts points to the *newest* released long-term support version.