summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2020-12-05 15:29:49 +0100
committerVivien Kraus <vivien@planete-kraus.eu>2021-06-19 15:44:21 +0200
commit023b4d96744145800069ba3342c0b9d7e809304f (patch)
tree44994d242154e8839ab76df92bfc895a2e22852c /configure.ac
parent671a159b2487efa67019b323ea7ac42793326e7e (diff)
Check that the code is indented on distcheck.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 44d902b..9b3b3b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,9 +3,14 @@ AC_CONFIG_SRCDIR([src/libwebidoidc.c])
AM_INIT_AUTOMAKE([subdir-objects])
AM_SILENT_RULES([yes])
+AC_ARG_ENABLE([--enable-indent-check],
+ [When running tests, also check that the source code is indented])
+
+AM_CONDITIONAL([INDENT_CHECK_ENABLED], [test "x$enable_indent_check" = "xyes"])
AC_PROG_CC
AM_MISSING_PROG([SNARF], [guile-snarf])
AM_MISSING_PROG([HELP2MAN], [help2man])
+AM_MISSING_PROG([INDENT], [indent])
LT_INIT
AC_CONFIG_HEADERS([config.h])
AM_GNU_GETTEXT([external])