summaryrefslogtreecommitdiff
path: root/src/scm/webid-oidc/client/Makefile.am
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2021-09-12 22:57:58 +0200
committerVivien Kraus <vivien@planete-kraus.eu>2021-09-14 16:06:43 +0200
commit328b4957d05fc9b0f9ff87f2a4932ae0296ab069 (patch)
tree2d44b7896c91f9934b470fd6bb54141ddc4dc714 /src/scm/webid-oidc/client/Makefile.am
parent6a83b79c4de5986ad61a552c2612b7cce0105cda (diff)
Restructure the client API
The client API had several problems: - using records instead of GOOPS means that we aren’t flexible enough to introduce accounts protected by a password, for a multi-user application; - saving the user database to disk means we can’t have a proper immutable API; - it was difficult to predict when the users database would change, and inform the user interface about this change; - it had two different ways to negociate an access token, one when we had a refresh token and one when we did not; - it was supposed to either use account objects or a subject / issuer pair, now we only use account objects.
Diffstat (limited to 'src/scm/webid-oidc/client/Makefile.am')
-rw-r--r--src/scm/webid-oidc/client/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/scm/webid-oidc/client/Makefile.am b/src/scm/webid-oidc/client/Makefile.am
index ccb7e35..583193e 100644
--- a/src/scm/webid-oidc/client/Makefile.am
+++ b/src/scm/webid-oidc/client/Makefile.am
@@ -15,7 +15,9 @@
# along with this program. If not, see <https://www.gnu.org/licenses/>.
dist_clientwebidoidcmod_DATA += \
- %reldir%/accounts.scm
+ %reldir%/accounts.scm \
+ %reldir%/client.scm
clientwebidoidcgo_DATA += \
- %reldir%/accounts.go
+ %reldir%/accounts.go \
+ %reldir%/client.go