summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2020-11-27 19:28:50 +0100
committerVivien Kraus <vivien@planete-kraus.eu>2021-06-19 15:44:24 +0200
commit7c81a49d762e67b21c99a95b86d1e7886d91de02 (patch)
tree41134870f6edc1b7b5567638f3740758ba5d0fe4 /tests/Makefile.am
parent9012da74345b0eea06ab36c93f2f36d5584a014c (diff)
Add a base64 encoder and decoder
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1e4b2df..12699f9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,4 +1,7 @@
-TESTS = %reldir%/load-library.scm
+TESTS = \
+ %reldir%/load-library.scm \
+ %reldir%/base64-ok.scm \
+ %reldir%/base64-error.scm
EXTRA_DIST += $(TESTS)
@@ -7,3 +10,9 @@ TEST_EXTENSIONS = .scm
AM_TESTS_ENVIRONMENT = $(top_builddir)/pre-inst-env
SCM_LOG_COMPILER = $(GUILE)
AM_SCM_LOG_FLAGS = --no-auto-compile -s
+
+clean-local: %canon_reldir%-clean-local
+
+%canon_reldir%-clean-local:
+ rm -rf %reldir%/*.cache
+ rm -rf %reldir%/*.home