summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2020-01-01 00:00:00 +0100
committerVivien Kraus <vivien@planete-kraus.eu>2021-06-18 15:43:45 +0200
commitee4b746fbfd39d44c9a4eb065e4eddc146903e02 (patch)
tree8e024633b455443eccfdc11c77b58b478eb8afba /tests/Makefile.am
parent7e125cc85c79e0854ca300dec6f819598e3fc6b0 (diff)
Add a random number generator.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 12699f9..adff911 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,18 +1,19 @@
-TESTS = \
- %reldir%/load-library.scm \
+TESTS = %reldir%/load-library.scm \
%reldir%/base64-ok.scm \
- %reldir%/base64-error.scm
+ %reldir%/base64-error.scm \
+ %reldir%/random.scm
EXTRA_DIST += $(TESTS)
TEST_EXTENSIONS = .scm
-AM_TESTS_ENVIRONMENT = $(top_builddir)/pre-inst-env
-SCM_LOG_COMPILER = $(GUILE)
-AM_SCM_LOG_FLAGS = --no-auto-compile -s
+.PHONY: %canon_reldir%-clean-local
clean-local: %canon_reldir%-clean-local
%canon_reldir%-clean-local:
rm -rf %reldir%/*.cache
- rm -rf %reldir%/*.home
+
+AM_TESTS_ENVIRONMENT = $(top_builddir)/pre-inst-env
+SCM_LOG_COMPILER = $(GUILE)
+AM_SCM_LOG_FLAGS = --no-auto-compile -s