summaryrefslogtreecommitdiff
path: root/vapigen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vapigen/Makefile.am')
-rw-r--r--vapigen/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/vapigen/Makefile.am b/vapigen/Makefile.am
new file mode 100644
index 0000000..f2abec3
--- /dev/null
+++ b/vapigen/Makefile.am
@@ -0,0 +1,22 @@
+# disfluid, implementation of the Solid specification
+# Copyright (C) 2021 Vivien Kraus
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as
+# published by the Free Software Foundation, either version 3 of the
+# License, or (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+.PHONY: update-vapi
+
+update-vapi:
+ $(MAKE) $(AM_MAKEFLAGS) -C .. src/client/disfluid-0.vapi
+
+all: update-vapi