summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2e0c05b4f7..3ed4a1900a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -501,6 +501,23 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(sha256 hash)))
+;; The current "mainline" kernel.
+
+(define-public linux-libre-6.9-version "6.9")
+(define-public linux-libre-6.9-gnu-revision "gnu")
+(define deblob-scripts-6.9
+ (linux-libre-deblob-scripts
+ linux-libre-6.9-version
+ linux-libre-6.9-gnu-revision
+ (base32 "1lzbn7v25473ggsjp6064ixhzir0y11h74hfxiav7zyjj64kvjiw")
+ (base32 "0a8ikg2b4q6xkd3pnzvd777ngrx74by7l13q7jg4n88myfxqk9xb")))
+(define-public linux-libre-6.9-pristine-source
+ (let ((version linux-libre-6.9-version)
+ (hash (base32 "0jc14s7z2581qgd82lww25p7c4w72scpf49z8ll3wylwk3xh3yi4")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-6.9)))
+
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
@@ -641,6 +658,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-6.9-source
+ (source-with-patches linux-libre-6.9-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-6.8-source
(source-with-patches linux-libre-6.8-pristine-source
(list %boot-logo-patch
@@ -761,6 +783,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-6.9
+ (make-linux-libre-headers* linux-libre-6.9-version
+ linux-libre-6.9-gnu-revision
+ linux-libre-6.9-source))
+
(define-public linux-libre-headers-6.8
(make-linux-libre-headers* linux-libre-6.8-version
linux-libre-6.8-gnu-revision
@@ -1105,6 +1132,14 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-6.9
+ (make-linux-libre* linux-libre-6.9-version
+ linux-libre-6.9-gnu-revision
+ linux-libre-6.9-source
+ '("x86_64-linux" "i686-linux" "armhf-linux"
+ "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-6.8
(make-linux-libre* linux-libre-6.8-version
linux-libre-6.8-gnu-revision